TLDR InfoSec · ATTACKS & VULNERABILITIES
APACHE WARNS OF CRITICAL VULNERABILITY IN STRUTS 2
Summary from the TLDR InfoSec newsletter
A new vulnerability, CVE-2023-50164, has been given a maximum severity rating. It affects Struts 2.0.0-2.3.37 (EOL), Struts 2.5.0-2.5.32, and Struts 6.0.0-6.3.0. An attacker can manipulate file upload parameters to enable path traversal and under some circumstances, this can lead to uploading a malicious file which can be used to perform remote code execution. Struts 2 developers and users are urged to immediately upgrade to version 2.5.33 or Struts 6.3.0.2, or greater.